Project

General

Profile

Errata-20161101-1 » History » Version 1

David Demelier, 11/01/2016 01:18 PM

1 1 David Demelier
h1. Errata 20161101.1
2
3
*Topic*: Invalid responses in plugin info command
4
*Category*: Plugins
5
*Corrected*: 2.0.3 (or revision ??)
6
*Affected versions*: 2.0.0
7
*Task*: #506
8
9
h1. Background
10
11
The plugin *auth* can authenticate the bot to NickServ or quakenet.
12
13
h1. Problem
14
15
The plugin uses a function Irccd.Logger.log which does not exist instead of Irccd.Logger.info.
16
17
h1. Solution
18
19
Upgrade to a newer version if applicable or apply one of the following fixes:
20
21
h2. Using Mercurial
22
23
If you don't have a local copy:
24
25
<pre>
26
hg clone -u release-2.0 http://hg.malikania.fr/irccd
27
</pre>
28
29
If you already have a local copy:
30
31
<pre>
32
cd /path/to/irccd
33
hg pull
34
hg up release-2.0
35
</pre>
36
37
And install new version of irccd.
38
39
h2. Using patch
40
41
Download the following patch:
42
43
* http://releases.malikania.fr/irccd/errata/20161101.1.patch
44
* http://releases.malikania.fr/irccd/errata/20161101.1.patch.asc
45
46
Apply it:
47
48
<pre>
49
cd /path/to/irccd/
50
patch -p1 < /path/to/20161101.1.patch
51
</pre>